No Audio on Macbook (and red light in headphone port)

I have recently had the misfortune of having the sound on my Macbook going off after about 10 minutes, and a red light appearing in the port.

After much research I found out that this is actually a VERY common problem (c’mon Apple you should fix this up). It seems to relate to plugging non-Apple plugs into your headphone port. Mine certainly happened when I started plugging in a lead to go to some external speakers. The problem is caused by a little switch inside the port which is there to sense whether they plug you plug in is optical or not. The larger plug size seems to cause it to somehow waver between detecting it as an optical port and not.

The standard advice to fix this is to ram your plug in and out a few, or to stick something in there and fiddle around at roughly the 7 o’clock position. I tried this and it worked for 10 minutes, then went off again.

What has worked for me is the advice from Macriot (sorry I can’t put the link in as Safari 4 crashes when I try, but it is http://www.macriot.com/article.php/20080718032528619). They say:

f you have these symptoms, we recommend a very gentle and minute tinkle of WD-40 into the audio output jack, followed by gently inserting and removing the audio input jack a few times. At least until the sound is returned to normal and red light ceases to glow from the audio output jack.Remember, we said “tinkle” not spraying into the jack like there’s no tomorrow…”

This seems to have done the trick for me and I have now been complete with audio for the last 4-5 hours! Hooray!

2 thoughts on “No Audio on Macbook (and red light in headphone port)”

Leave a Reply to ricardo Cancel reply

Your email address will not be published. Required fields are marked *